Browser Bug Hunt for LessWrong.com migration

As we get ready for the fi­nal move of lesser­wrong.com to less­wrong.com, we’re ad­dress­ing var­i­ous browser com­pat­i­bil­ity is­sues.

We’ve re­cently up­dated some com­pat­i­bil­ity tools that fixed sev­eral of the older bugs. If you’ve run into com­pat­i­bil­ity bugs in the past, and are us­ing one of our (newly) sup­ported browsers, it’d be helpful if you tried us­ing lesser­wrong.com again and see if you run into any is­sues.

The site does re­quire javascript to lo­gin and in­ter­act, al­though we’ll try to make it a fairly friendly read­ing ex­pe­rience, and users who pre­fer a non-javascript ex­pe­rience can use sat­urn’s greater­wrong.com.

The old­est browsers we’re offi­cially try­ing to sup­port are:

  • Fire­fox 45

  • Chrome 49

  • Sa­fari 9

  • In­ter­net Ex­plorer 11

  • Edge

  • Sam­sung In­ter­net 6

(Th­ese are all the browsers that make up more than .4% of our user­base. If there turn out to be ma­jor is­sues for other browsers we’ll try to look into them but can’t nec­es­sar­ily promise to pri­ori­tize them all uniformly highly. It’s still use­ful to have the bugs col­lected so we have a sense of the spread of is­sues across var­i­ous de­vices)

Let us know what is­sues you’ve run into. Please in­clude your browser and OS (and ver­sion). Bonus points if you try to repli­cate the is­sue in an­other browser to help tri­an­gu­late what soft­ware is caus­ing prob­lems.